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Five Year LimitedWarranty
Spectracom, a business of the Orolia Group,
warrants each new standard product to be
free from defects in material, and work
manship for five years after shipment in most
countries where these products are sold,
EXCEPT AS NOTED BELOW (the “Warranty
Period” and "Country Variances").

Warranty Exceptions
This warranty shall not apply if the product is
used contrary to the instructions in its manual
or is otherwise subjected to misuse, abnormal
operations, accident, lightning or transient
surge, or repairs or modifications not per
formed by Spectracom authorized personnel.
Items with a variance to the Five Year War
ranty Period are as follows:

90 DaysWarranty
TimeKeeper Software

One Year LimitedWarranty
Timeview Analog Clock
Path Align-R Products
Bus-level Timing Boards
IRIG-B Distribution Amplifiers

Two Year LimitedWarranty
Rubidium Oscillators
Epsilon Board EBO3
Epsilon Clock 1S, 2S/2T, 3S, 31M
Epsilon SSU
Power Adaptors
Digital and IP/POE Clocks
WiSync Wireless Clock Systems and IPSync
IP Clocks

Rapco 1804, 2804, 186x, 187x, 188x,
189x, 2016, 900 series

Three Year LimitedWarranty
Pendulum Test & Measurement Products GPS-
12R, CNT-9x, 6688/6689, GPS-88/89, DA-
35/36, GPS/GNSS Simulators

Country Variances
All Spectracom products sold in India have a
one year warranty.

Warranty Exclusions
Batteries, fuses, or other material contained
in a product normally consumed in oper
ation.
Shipping and handling, labor & service fees
EXCEPT FOR THE LIMITED WARRANTY
STATED ABOVE, SPECTRACOM DISCLAIMS
ALL WARRANTIES OF ANY KIND WITH
REGARD TO SPECTRACOM PRODUCTS OR
OTHER MATERIALS PROVIDED BY
SPECTRACOM, INCLUDING WITHOUT
LIMITATION ANY IMPLIED WARRANTY OR
MERCHANTABILITY OR FITNESS FOR A
PARTICULAR PURPOSE.
Spectracom shall have no liability or respons
ibility to the original customer or any other
party with respect to any liability, loss, or
damage caused directly or indirectly by an
Spectracom product, material, or software
sold or provided by Spectracom, replace
ment parts or units, or services provided,
including but not limited to any interruption of
service, excess charges resulting from mal
functions of hardware or software, loss of
business or anticipatory profits resulting from
the use or operation of the Spectracom
product or software, whatsoever or
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howsoever caused. In no event shall
Spectracom be liable for any direct,
indirect, special or consequential dam
ages whether the claims are grounded in
contract, tort (including negligence), or
strict liability.

ExtendedWarranty Coverage
Extended warranties can be purchased
for additional periods beyond the stand
ard warranty. Contact Spectracom no
later than the last year of the standard
warranty for extended coverage.

Warranty Claims
Spectracom’s obligation under this war
ranty is limited to the cost of in- factory
repair or replacement, at Spectracom’s
option, of the defective product or the
product’s defective component. Spec
tracom’s Warranty does not cover any
costs for installation, reinstallation,
removal or shipping and handling costs
of any warranted product. If in Spec
tracom’s sole judgment, the defect is not
covered by the Spectracom Limited War
ranty, unless notified to the contrary in
advance by customer, Spectracom will
make the repairs or replace components
and charge its then current price, which
the customer agrees to pay.
In all cases, the customer is responsible
for all shipping and handling expenses
in returning product to Spectracom for
repair or evaluation. Spectracom will
pay for standard return shipment via
common carrier. Expediting or special
delivery fees will be the responsibility of
the customer.

Warranty Procedure
Spectracom highly recommends that
prior to returning equipment for service

work, our technical support department
be contacted to provide troubleshooting
assistance while the equipment is still
installed. If equipment is returned without
first contacting the support department
and “no problems are found” during the
repair work, an evaluation fee may be
charged.
Spectracom shall not have any warranty
obligations if the procedure for warranty
claims is not followed. Customer must
notify Spectracom of a claim, with com
plete information regarding the claimed
defect. A Return Authorization (RMA)
Number issued by Spectracom is
required for all returns.
Returned products must be returned with
a description of the claimed defect, the
RMA number, and the name and contact
information of the individual to be con
tacted if additional information is
required by Spectracom. Products being
returned on an RMA must be properly
packaged with transportation charges
prepaid.
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Upgrade Preparation

Chapter 1 guides you through the steps necessary to prepare the
upgrade.

This Chapter includes the following topics:

1.1 Determining the Current System Software 8
1.1.1 Using Version 5.1.2 and Above 8
1.1.2 Using Version 5.0.2 and Below ("Old Style"
Web UI) 8

1.2 Determining the GNSS Receiver 9
1.3 Determining the Correct Upgrade Procedure 10
1.4 Freeing up Disk Space 11
1.4.1 Archiving and Deleting Log Files 12
1.4.2 Deleting Previous Update Files 12

1.5 Downloading the Upgrade Software Bundle 13
1.6 Option-Specific Steps 13
1.6.1 Gigabit Ethernet Option 14

CHAPTER 1 • NetClock 9400 SW Upgrade Instructions V5.2.0 7

C
H
A
PT
ER

1



1.1 Determining the Current System Software
First, determine which system software version is currently installed on your NetClock 9400:

1.1.1 Using Version 5.1.2 and Above

1. In the NetClock 9400 Web User Interface (Web UI), navigate to Tools > System >
Upgrade/Backup.

2. Take note of the system software version number.

1.1.2 Using Version 5.0.2 and Below ("Old Style" Web UI)

1. In the Web UI, navigate to Tools > Versions.
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2. Take note of the Archive Version number.

1.2 Determining the GNSS Receiver
Next, you need to determine which type of GNSS receiver is installed in your NetClock 9400.

NOTE – If the default Web UI of your unit is blue/white (rather than dark grey),
your unit has a Res-T receiver.

1. If your Web UI is dark grey (see illustration below), navigate to Interfaces -> GNSS 0.
The first line item under the default Main tab will report the GNSS receiver Model that is
installed in your NetClock 9400. The example shown in the illustration below shows a
"RES-SMTGG" receiver.

1.2  Determining the GNSS Receiver
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2. Take note of the receiver type installed in your unit.

1.3 Determining the Correct Upgrade Procedure
The Version 5.2.0 Ugprade Bundle you are about to install includes a firmware update (Version
1.0.7) for the GNSS receiver in your NetClock 9400. Units shipped since 1 April 2014 typ
ically have a "RES- SMT-GG" GNSS receiver installed, for which the Version 1.0.7 firmware
update has been designed.

NOTE – If your unit is equipped with a GNSS receiver different than the "RES-
SMT-GG" receiver, the firmware update will be skipped automatically.

In order for the firmware update to be applied to the GNSS receiver during the NetClock 9400
system software upgrade process, the starting system software version must be Version 5.1.5 or
higher.

This requirement results in three possible scenarios:

I. Your NetClock 9400 has system software version 5.1.5 or higher installed.
In this case, the receiver firmware update will be automatically applied during the sys
tem software upgrade process. After completion of all necessary steps outlined in
CHAPTER 1, proceed to "Upgrading from V. ≥5.1.2 to V. 5.2.0" on page 24.

II. The system software installed on your NetClock 9400 is version 5.1.4 or below, but is at
least version 5.0.2:
In this case, the system software does not need to be updated first to version 5.1.5,
before updating to version 5.2.0. Instead, the same version 5.2.0 update process must
be performed a second time, with the second update process only applying the firm
ware update to the RES-SMT-GG receiver (if installed); see also "Required Repeat of Ver.
5.2.0 Update Process" on page 23.
The second time performing the same update process does require the update file to be
uploaded into the time server again, but does not require the Force Update checkbox
be enabled, as the rest of the update process does not need to be performed again
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(NetClock 9400 will already be at Version 5.2.0 at that time).
After completion of all necessary steps outlined in CHAPTER 1, proceed to "Upgrading
from V. 5.0.2 to V. 5.2.0" on page 18.

III. If the currently installed software version is versions 5.0.1 or below: You must install
Version 5.0.2 first. Please visit the Spectracom web page SecureSync and NetClock
9400 Software Upgrade, in order to receive the corresponding upgrade bundle.

1.4 Freeing up Disk Space
NetClock 9400 uses a Compact Flash (CF) memory card for storing logs, configurations and
software. Over time, the Compact Flash card can contain many log entries and any previous
software update files retained from earlier software updates.
If the CF card usage is higher than normal when a software update is performed, this can
potentially result in the loss of some or all of the unit’s configurations upon completion of the
software update process or may prevent the update from being able to begin. It may be neces
sary for the unit’s logs and previous update files to be deleted before performing software
updates.
The logs can be backed-up to a single bundled fine and then extracted before deleting them, if
required by your organization. The processes to easily delete logs and previous Update files
before updating the software is described within.

NOTE – An available CLI command (df –h) can be used to read what percentage
of the CF card is currently in use, to determine if the logs and update files should
be deleted. In general, if the CF card usage is more than around 70 % or so, the
logs and any previous software update files should be deleted to ensure there is
plenty of space in the CF card to persist the config files and to be able to perform
the upgrade. 

To determine the usage, login to the CLI (telnet or ssh) and at the command prompt, type: df –h
<enter> (as shown below). The “Use%” column in the “/dev/hda1” row will indicate the CF
card usage (65 % in this example, which indicates the logs and any previous Update files don’t
need to be deleted before performing the update process.

1.4  Freeing up Disk Space
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1.4.1 Archiving and Deleting Log Files
If the disk usage is higher than around 70 %, Spectracom recommends the logs (and update
files that may have been previously applied) be deleted before performing the system software
upgrade to prevent possible loss of configuration data during the software update process.
As an option, the logs can also be backed-up before deletion: The logs can be bundled into a
single file, and then transferred to your PC, all from within the Web UI.

1. The log bundling and deleting is controlled in the Management > “Log Configuration
page. To save the logs to a PC before deleting them, on the left side of the page, click
on Save and download all Logs. This generates a single bundled file of the logs. Select
where to save this file on your PC.
Alternatively, the logs can also be deleted under Management > Log Configuration. On
the left side of the page, click on Clear all Logs.

The logs have now been deleted.

1.4.2 Deleting Previous Update Files
Previous Update files are stored in the home/spectracom directory and can be indi
vidually deleted using the Web UI (they are not used by the system after the update has been
applied).
To delete each update file:

1. Open the Web UI, and login. Then, navigate to the Tools > Upgrade/Backup (see illus
tration below).

2. Click on the button Update System Software in the top-left corner of the
Upgrade/Backup page, in order to open the window Upgrade System Software (see
illustration below).
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3. The drop-down list will display each update file currently stored in the Compact Flash
Card. Select the file to be deleted, and check the Delete Upgrade File checkbox. Then
click Submit.

4. Repeat this process to delete any other listed update file.

1.5 Downloading the Upgrade Software Bundle
The version 5.2.0 system software upgrade (as well as previous versions 5.0.2 and 4.8.9, as
needed) can be downloaded from the Spectracom Corporate website, see:
Spectracom Corporate website/Support page for NetClock

1. Download the file onto your PC, and note the location.

1.6 Option-Specific Steps
With certain options (see below), the corresponding procedures described below must be car
ried out when upgrading from Versions 5.0.2 or higher to Version 5.2.0.
These instructions apply only, if one or several of these options are installed:

10/100 PTP Option

Gigabit Ethernet Option

Please note that these option-related procedures must be carried out only once, i.e. if you have
previously upgraded your system from Version 5.0.2 to, e.g. 5.1.5, you can skip this section.

When there are software updates that need to be automatically applied to the 10/100 PTP
Option during the upgrade process, the upgrade process will take an additional 5 to 7 minutes
longer, for each 10/100 PTP Option Module that is installed.

1.5  Downloading the Upgrade Software Bundle

CHAPTER 1 • NetClock 9400 SW Upgrade Instructions V5.2.0 Rev. [1] 13

http://www.spectracomcorp.com/Support/HowCanWeHelpYou/Software/tabid/61/Default.aspx#SecureSync


1.6.1 Gigabit Ethernet Option

NOTE – This section is not applicable when previously upgrading from versions
5.1.2 and above and the Ethernet ports have already been enabled by a user.

Important Notices when upgrading from version 5.0.2
When updating from versions prior to 5.1.2 with this Option installed, Eth1, Eth2 and Eth3 will
all be disabled (not accessible by the network) upon applying this software update. If you are
connected to one of these three ports to perform the update process, the time server will not be
accessible once the update has completed.  Further below is information about two different
methods to enable each of these three Interfaces as desired, after applying the software
update.
Because the three interfaces are disabled once the software update has completed, the network
settings will appear to have been lost during the update.  However, the settings do actually per
sist through the update process. All of the settings will be present again, once each interface is
individually enabled. 
If the software was previously updated to versions 5.1.2 or higher, the three Ethernet ports will
be in the same state (enabled or disabled) as they were before applying this update.
System software version 5.1.2 added a new feature which allows unused Ethernet interfaces
(Eth1, Eth2 and/or Eth3) of the Gigabit Option , if installed, to be disabled via software for
security purposes.  Note this change does not apply to the base Ethernet port, “Eth0”, which
cannot be disabled.
After applying this software update from version 5.0.2, all three of these Ethernet interfaces will
be disabled.  If any or all three of these interfaces are currently being used, after applying the
software update (or if it’s desired to start using any of these three interfaces at a later date) the
desired Ethernet interface(s) needs to be enabled.  Until the interfaces have been enabled by a
user, they will be inaccessible to the network.
Each of the three Ethernet interfaces can be enabled as desired, via either the web browser
(using the “base” Ethernet interface “Eth0”) or by issuing a specific command with a CLI con
nection (telnet or SSH).

Enabling each interface using a CLI connection
After creating a CLI connection (using either telnet or SSH) the command to enable each
desired interface is as follows: portset x on (where x is the Ethernet interface number - 1, 2, or
3 - for the interface you wish to enable).
An example of enabling Interface “Eth1” is shown below:

Enabling each interface using a web browser connection
To enable each desired Interface using the web browser, login to the browser using Eth0 (this
interface is not disabled during the update).  Navigate to the Management -> Network page of
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the Web UI. This will open a page displaying all four Ethernet interfaces (Eth0 through Eth3). 
The Status of Eth1 through Eth3 will be displayed as “DISABLED”. 
For each Interface you wish to enable, click on the corresponding Gear button (center of the
three buttons in that row). In the next screen that opens, click on the checkbox at the top of the
page (as shown below). Then press either the Apply or Submit button to enable the interface. 
The port will now have the previous configuration as before the update was applied and will
be accessible to the network.

1.6  Option-Specific Steps
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BLANK PAGE.

1.6  Option-Specific Steps
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Upgrade Procedure

After completion of all preparation steps, the actual upgrade will be
performed. Chapter 2 will guide you through the procedure.

Depending on which software version is currently installed in your
NetClock 9400, proceed either to:

"Upgrading from V. 5.0.2 to V. 5.2.0" on the next page,

or to "Upgrading from V. ≥5.1.2 to V. 5.2.0" on page 24.

This Chapter includes the following topics:

2.1 Upgrading from V. 5.0.2 to V. 5.2.0 18
2.1.1 Required Repeat of Ver. 5.2.0 Update Pro
cess 23
2.1.2 Confirming Successful Installation 23

2.2 Upgrading from V. ≥5.1.2 to V. 5.2.0 24
2.2.1 Potential Need to Repeat Ver. 5.2.0
Update Process 29
2.2.2 Confirming Successful Installation 29
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2.1 Upgrading from V. 5.0.2 to V. 5.2.0
The software upgrade process is performed using a Windows PC that is either on the same net
work as the NetClock 9400 appliance, or is connected directly to the NetClock 9400 via a net
work cable.

NOTE – In order to perform the software upgrade, the Web UI of the unit to be
upgraded must be accessible from this particular PC.

Once you downloaded the upgrade file onto a network PC, you can then transfer the file onto
your NetClock 9400 unit, using the unit's Web UI.

NOTE – Alternatively, you can also upgrade via Command Line Interface: In this
case, the file must be transferred manually, using FTP/SFTP, to the NetClock 9400
directory home/spectracom.

During the time that the file is being uploaded into NetClock 9400, the unit will remain fully
functional and accessible for other network PC's.
Once the file transfer is complete, NetClock 9400 is performing the software upgrade
("Upgrade System"), during which the unit is configured: Normally, all current NetClock 9400
configurations are automatically saved and restored as part of the update process. During the
“Upgrade System” process, the front panel LCDs will go blank, and the unit will not be oper
ational until the upgrade process has completed.

1. Download the NetClock 9400 ugrade file (update520.tar.gz) from the Spec
tracom website—see also "Downloading the Upgrade Software Bundle" on page 13—
to an accessible directory on your local Windows machine (such as C:/Temp).

2. Open the Web UI, and login. Then navigate to Tools > Upgrade/Backup.

3. Ensure the Software/License Upgrade tab is orange (Orange indicates the tab is selec
ted). Either click in the blank text box located next to Upload File, or select Browse to be
able to select the update file (see illustration below).
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4. Use the Windows® Explorer to navigate to the location on your network PC where the
update file (update520.tar.gz) was stored earlier (such as C:/Temp), and select
it. Once the path appears in the text field (see illustration below), click the Upload but
ton.

5. The file upload process may take several minutes. Once the file has been uploaded, the
message “The file updatexxx.tar.gz has been uploaded.” (where xxx is the new version
being applied) will be displayed underneath the field Upload Update/License File:

6. Now refer to the bottom of this page, under the title Upgrade the System. Ensure the cor
rect file name (update520.tar.gz) is selected in the box next to Update File.

7. Check the box next to Update System to install the software update.

Other available checkboxes:

2.1  Upgrading from V. 5.0.2 to V. 5.2.0

CHAPTER 2 • NetClock 9400 SW Upgrade Instructions V5.2.0 Rev. [1] 19



NOTE – To perform the software update from an earlier software version to the
latest version, only the checkbox next to Update System should be selected.

Force Update: When checked, will force the software to install all packages, even if it is
already at the current revision, or (for example, it iss desired to install version 5.2.0,
even though version 5.2.0 is already installed). The software will reinstall over the pre
viously installed packages.

USE CASE: This checkbox must be selected if it is ever desired to downgrade to a pre
vious software version.

Delete Update File: When checked, will remove the Archive file that was uploaded into
the unit. Note that this will not remove the file from your PC, just from NetClock 9400.

NOTE – If it is desired to remove the update file from the unit after com
pletion of the upgrade process, note that the “Delete the Update File” check
box should not be selected at the same time as the “Update System”
checkbox. This process should be performed any time after the System
Update process has been completed.

Restore Factory Configuration: When checked, will return NetClock 9400 to its original
factory configuration.

USE CASE: This checkbox should be selected if it is ever desired to downgrade to a pre
vious version (such as back to version 5.0.2, for instance).

During the System Upgrade you will see an analysis screen (as shown in the illustration below).

NOTE – If the unit has had any previous software updates applied and if any of
the earlier upgrade files have not since been deleted from the unit, a Web UI
screen may momentarily indicate the Upgrade process is “Complete”.  This does
not affect the software update process and the analysis screen will be displayed
shortly thereafter.
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NOTE – “OC” being displayed in the bottom rows refers to OPTIONS which may
or may not be installed in your unit.

Caution: Do not close the Web UI, or attempt to reboot the unit. The installation is
in progress and may take several minutes to complete.

NetClock 9400 will reboot itself during the update process, as shown in the following screen
shot:

2.1  Upgrading from V. 5.0.2 to V. 5.2.0
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NOTE – If using a DHCP assigned IP address (instead of having a statically
assigned IP address), the unit’s IP address may change once the update has com
pleted (it may be re-assigned a different IP address by the DHCP server). Auto
matic Reloading of the Web UI will not work if the address has been changed by
the DHCP server. Therefore, a new web browser connection using the newly
assigned IP address will need to be opened.

If the front panel LCD is configured to display network settings, the LCD window will show the
newly assigned IP address.
When using a static-assigned IP address (or if the DHCP server did not assign a new IP address
after the reboot), and as long the Web UI did not time-out during the update process (if it times-
out, press the F5 key to refresh the connection), once the update is complete, you will now see
the main page of the "new" Web UI design.
If you need to reconnect to the Web UI at any point, the login screen for the new Web UI
design will now look like the following:

With the new Web UI design, the Upgrade Log with is located in the upper-right corner of the
Home page. The top of this log should indicate “Successful”.
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2.1.1 Required Repeat of Ver. 5.2.0 Update Process
IMPORTANT: The upgrade process must be performed a second time, if:

you are upgrading from a software version 5.1.4 or lower (as described in this
chapter)

and if your unit is equipped with a RES-SMT-GG receiver.

This is required to update the receiver firmware.
(If the pre-upgrade software was version 5.1.5 or higher, or if a receiver other than RES-SMT-
GG is installed, the update process does not need to be repeated.)

Caution:Note the second time performing the same update process does require
the update file be uploaded into the unit again. The checkbox Force Update must
NOT be checked.

With update520.tar.gz in the update drop-down list after re- loading the update file, just
select Perform Upgrade again and click Submit. The second time through the update process
will be faster than the first time, as the receiver is the only item updated.

2.1.2 Confirming Successful Installation
Navigate to Tools > Upgrade/Backup. The following information should now be displayed:

2.1  Upgrading from V. 5.0.2 to V. 5.2.0
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2.2 Upgrading from V. ≥5.1.2 to V. 5.2.0
The software upgrade process is performed using a Windows PC that is either on the same net
work as the NetClock 9400 appliance, or is connected directly to the NetClock 9400 via a net
work cable.

NOTE – In order to perform the software upgrade, the Web UI of the unit to be
upgraded must be accessible from this particular PC.

Once you downloaded the upgrade file onto a network PC, you can then transfer the file onto
your NetClock 9400 unit, using the unit's Web UI.

NOTE – Alternatively, you can also upgrade via Command Line Interface: In this
case, the file must be transferred manually, using FTP/SFTP, to the NetClock 9400
directory home/spectracom.

During the time that the file is being uploaded into NetClock 9400, the unit will remain fully
functional and accessible for other network PC's.
Once the file transfer is complete, NetClock 9400 is performing the software upgrade
("Upgrade System"), during which the unit is configured: Normally, all current NetClock 9400
configurations are automatically saved and restored as part of the update process. During the
“Upgrade System” process, the front panel LCDs will go blank, and the unit will not be oper
ational until the upgrade process has completed.

1. Download the NetClock 9400 ugrade file (update520.tar.gz) from the Spec
tracom website—see also "Downloading the Upgrade Software Bundle" on page 13—
to an accessible directory on your local Windows machine (such as C:/Temp).

2. Open the Web UI, and login. Then navigate to Tools > Upgrade/Backup.

3. Click the button Update System Software in the top-left corner of the Upgrade/Backup
page:
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4. Click Browse…, and navigate to the location to which you previously saved the update
file (update520.tar.gz) on your PC (such as C:/Temp). Select the file. The file
name will appear next to the Browse… button.

5. Click Upload.

6. The file upload process may take several minutes. Once the file has been uploaded into
your NetClock 9400, the directory of updatexxx.tar.gz (where xxx is the version)
will be listed in the “File” dropdown, (The “down arrow” to the right-side of this field
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may need to be clicked, in order to see the file, if previous update files have been
uploaded).

7. Ensure the correct file name (update520.tar.gz) is selected in the “File” drop-
down field.

8. Check the box next to Perform Upgrade to install the software update (or to downgrade
to an earlier version).
Once this checkbox has been selected, two other checkboxes (Force Upgrade and Clean
Upgrade) will become visible towards the bottom of the window. Note that these two
checkboxes do not need to be selected for a standard upgrade to a newer version.

Force Upgrade — When checked, will force the software to install all update packages,
even if it is already at the current revision, (for example, it is desired to install version
5.2.0, even though version 5.2.0 is already installed). The software will reinstall over the
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previously installed packages.

USE CASE: This checkbox needs be selected if it is ever desired to downgrade to a pre
vious version of Software.

Clean Upgrade — When checked, will return the NetClock 9400 to its original factory
configuration for the version of software being installed. (The Force Upgrade checkbox
will be automatically selected when the Clean Upgrade checkbox is selected.)

NOTE – To perform a standard software upgrade, i.e. from an earlier software
version to the latest version, only the checkbox Perform Upgrade needs to be selec
ted.

During the System Upgrade process, the Upgrade Log window on the right-side of the browser
will periodically have new entries asserted, indicating the update process is progressing.

Caution: Do not close the Web UI, or attempt to reboot the unit. The installation is
in progress and may take several minutes to complete.
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The Upgrade Status window will remain displayed during the upgrade progress, as long the
browser is not refreshed (such as by pressing the keyboard F5 key, for instance) or as long as
the web browser background is not clicked. If the page happens to be refreshed or the back
ground clicked during the next few minutes while the update is being performed (causing the
Status window to disappear), this Status window cannot be re-opened. However, the software
update will continue to be performed with the window closed (the Upgrade Status window and
the Web UI being open are not required for the update to be performed). The Status window
will periodically report status change updates.

NOTE – If using a DHCP assigned IP address (instead of the unit having a stat
ically assigned IP address), the IP address may change once the update has com
pleted (it may be re-assigned a different IP address by the DHCP server).

Automatic Reloading of the web page will not work if the address has been
changed by the DHCP server. Therefore, a new web browser connection using
the newly assigned IP address will need to be opened.

If the front panel LCD is configured to display network settings, the LCD window will show the
newly assigned IP address.
When using a static-assigned IP address (or if the DHCP server did not assign a new IP address
after the reboot), and as long the web browser didn’t time-out during the update process (if it
times-out, press the F5 key to refresh the connection), once the update is complete, you will now
see the main page of the new web browser design.

Upgrade Log
The Upgrade Log is located in the upper-right corner of the Tools > Upgrade/Backup page of
the Web UI. After completion of the upgrade process, the top of this log should indicate “Suc
cessful”.
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2.2.1 Potential Need to Repeat Ver. 5.2.0 Update Process
IMPORTANT: The upgrade process must be performed a second time, if:

you are upgrading from a software version 5.1.4 or lower

and if your unit is equipped with a RES-SMT-GG receiver.

This is required to update the receiver firmware.
(If the pre-upgrade software was version 5.1.5 or higher, or if a receiver other than RES-SMT-
GG is installed, the update process does not need to be repeated.)

Caution:Note the second time performing the same update process does require
the update file be uploaded into the time server again. The checkbox Force
Update must NOT be checked.

With update520.tar.gz in the update drop-down list after re- loading the update file, just
select Perform Upgrade again and click Submit. The second time through the update process
will be faster than the first time, as the receiver is the only item updated.

2.2.2 Confirming Successful Installation
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NOTE – You will need to log into the Web UI, using your login account inform
ation

Navigate to Tools > Upgrade/Backup. The following information should now be displayed:
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This Chapter includes the following topics:

3.1 Upgrading via CLI ii
3.2 Saving/restoring configuration files ii
3.3 Software Update Log entries iii
3.4 Downgrading the SW to a Previous Version iii
3.5 “Upgrade Failure” (V. 5.0.2 to V. 5.2.0) v
3.6 “Upgrade Failure” (V. ≥5.1.2 to V. 5.2.0) vii
3.7 Technical Support ix
3.7.1 Regional Contact ix
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3.1 Upgrading via CLI
It is possible perform a software upgrade via a Command Line Interface, rather than using the
Web UI, for example for scripting software updates.
Starting in Archive software version 4.8.8, the software update can be initiated using a CLI
command (issued via telnet, SSH or the front panel Serial port), instead of using the web
browser, if desired. This entails performing an FTP/SCP transfer of the software update file into
NetClock 9400’s /home/spectracom directory and then issuing the sysupgrade CLI com
mand to initiate the software upgrade.

NOTE – IMPORTANT: When transferring the update file using either FTP or SCP
(instead of uploading it using the web browser), make sure the Update file is
transferred using BINARY mode (SCP transfer is preferred, because it always
transfers using Binary mode).  Otherwise, this file will likely be altered during the
file transfer, preventing the updater from being able to extract it. The following
error message will be asserted into the Update log if the Update file is
altered/can’t be extracted:  “ERROR (- 1) - Failure while unpacking Upgrade
Bundle  (SWUE)”.

The syntax for issuing the sysupgrade command is:

Standard upgrade (Such as upgrading versions 4.8.8 to 4.8.9 for example): “sysup
grade” followed by the upgrade file name (Example: sysupgrade update489.tar.gz).

Forced upgrade (Such as downgrading versions 4.8.9 to 4.8.8 for example, but can also
be used with Standard upgrades, also):  “sysupgrade force” followed by the upgrade
file name (Example: sysupgrade force update489.tar.gz).

Clean upgrade (Such as first performing a Forced upgrade from 4.8.8 to 4.8.9, for
example. Then automatically resetting the NTP server back to factory default settings and
deleting all log files):  “sysupgrade clean” followed by the upgrade file name (Example:
sysupgrade clean update489.tar.gz).

3.2 Saving/restoring configuration files

Important note about saving/restoring configuration files
Due to fairly significant changes to the system configuration files from system software versions
prior to version .20, it is not recommended to perform a configuration restore with 5.2.0 soft
ware installed, from a configuration save that was performed in a NetClock 9400with versions
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4.8.9 or earlier installed.  If a configuration restore from versions 4.8.9 or below software is
performed on a version 5.x.x time server, a ‘clean’ will be required to be performed via the
front panel keypad thereafter to reset the NTP server to the factory default settings for the
installed version.
In general, due to possible changes to configuration files from one version to another, if you
wish to have a configuration backup file saved, we recommend performing a new “con
figuration save” after each new software update is performed, to replace the earlier con
figuration bundle.  This will ensure that if a configuration restore is performed, the configs in
the captured file will be identical to the ones in the NTP server.

3.3 Software Update Log entries
Software update log entries, such as upgrades that have already been performed, or an error
occurring during the update process, are placed in the Update Log (Tools > Logs page of the
Web UI). Please refer to this log if you have any problems with the software update process
(such as if the message “Upgrade Failure” is displayed, for instance).

3.4 Downgrading the SW to a Previous Version
If desired, the software can be downloaded to previous versions 5.0.0 or higher (it is not
recommended to downgrade to versions 4.8.9 or below from versions 5.0.0 and above). The
downgrade process is the same as an upgrade, except an earlier version update bundle is
selected during the process and the update needs to be "Force Updated" (to override the ver
sion checking that normally occurs).

NOTE – Due to incompatibilities between later and earlier configuration files, a
“Clean Upgrade” is also required to be performed during the software “down
grade” process (the unit will need to be reconfigured as desired, once it’s been
downgraded to the desired, earlier version).

NOTE – You will not be able to apply a Saved configuration file from a later ver
sion of software to any earlier, downgraded version of software to restore the
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configurations. However, a saved config file previously performed when it was at
the earlier version can be safely re-applied as desired to restore configs.

Downgrading to an earlier version using the newer (black/charcoal background)
Web UI:
To simultaneously downgrade and ‘Restore Factory Configuration”:

1. Navigate to the Tools > Upgrade/Backup page.

2. Press Update System software (on the left side of the screen, under Actions).

3. Verify the desired update bundle you wish to downgrade to is in the File drop-down.  If
not, press Upload New File and browse to where the earlier update bundle is stored.
Upload the bundle into the unit.

4. Select the Perform Upgrade checkbox in the menu that opens, which will expand the
menu down to display two additional checkboxes.

5. Select the desired Update bundle version which you wish to downgrade to.

6. Select also the Force Upgrade and Clean Upgrade checkboxes, before clicking Submit 
(as shown in the screenshot below) to begin the downgrade. The software downgrade
will take several minutes to complete.

NOTE – If the software was downgraded back to a version prior to version 5.1.0,
the “classic interface” will be displayed after logging back in, once the down
grade has completed.
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7. Once downgraded, reconfigure the unit’s settings as desired, or restore a previously
Saved config file from the version the software has been downgraded to.

Downgrading to an earlier version using the “classic interface”Web UI
To simultaneously downgrade and Restore Factory Configuration, in addition to selecting the
Update System, and Force Update checkboxes, also select the Restore Factory Configuration
checkbox before clicking Submit (as shown in the screenshot below). The software downgrade
will take several minutes to complete.
The Restore Factory Configuration checkbox resets all of the unit’s configurations back to the
factory default settings.

NOTE – If the software was downgraded back to a version prior to version 5.1.2,
the “classic" interface will be displayed after logging back in, once the down
grade has completed.

Reconfigure the settings as desired, or restore a previously Saved config file from the version
the software has just been downgraded to.

3.5 “Upgrade Failure” (V. 5.0.2 to V. 5.2.0)
If the Update process returns “Upgrade Failure” (as shown below), the software update process
was not successful.

If this happens, review the entries in the Update and System logs.
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Applying the same version already installed or downgrading to an earlier version of software
without select the “Force Update” checkbox, in addition to selecting the “Update System” check
box can cause the upgrade to fail. Make sure to select “Force update when applying the same
or earlier version of software.
The Update log may contain the following entry:  “Error (-1) Failure while unpacking Upgrade
Bundle” / “Problem unpacking NWP bundle” *as shown below):

Likely causes for this error message in the Update log

The update file may be corrupt (preventing it from being able to be extracted in the time
server). Run MD5 checker against the update file to verify file integrity. Spectracom
provides the MD5 file for each software update file.

Too many Update Bundles are stored in the time server.  Delete previous update bundles
(such as update489, for instance).

Once a software update has been applied, the update bundle can be deleted (the bundles only
need to be stored in the time server to alleviate the need to transfer them again to perform a
software downgrade.  Otherwise, they can be safely deleted without affecting the time server). 
Having too many upgrade files saved can prevent the update file being applied from being
able to extract.
To delete earlier update files, select each one individually in the drop-down, check only the
“Delete Update File” checkbox in the screen where you normally select “Update File”.  Then
press Submit. This will delete the selected update file. Then run the update process again.
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3.6 “Upgrade Failure” (V. ≥5.1.2 to V. 5.2.0)
If the Update process returns “Upgrade Failure” (as shown below), the software update process
was not successful. Note that starting the update process again after it is already been started
will result in an “upgrade failure” of the subsequent update process, while the first one is still
being performed in the background.
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If this happens, review the entries in the Update and System logs.

1. The time server may be retaining earlier upgrade bundle files which were applied and
are no longer needed.  Previous update bundles should be deleted. For more inform
ation, see "Deleting Previous Update Files" on page 12.

2. Applying the same version already installed or downgrading to an earlier version of
software without select the “Force Update” checkbox, in addition to also selecting both
the “Force Upgrade” and “Clean Upgrade” checkboxes can cause the upgrade to fail.
Make sure to select the “Perform Upgrade”, “Force Upgrade” and “Clean Upgrade”
checkboxes when applying the same or earlier version of software.

3. The Update log may contain the following entry:  “Error (-1) Failure while unpacking
Upgrade Bundle” / “Problem unpacking NWP bundle”

Likely causes for this error message in the Update log

The update file may be corrupt (preventing it from being able to be extracted in the time
server). Run MD5 checker against the update file to verify file integrity. Spectracom
provides the MD5 file for each software update file.
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Too many Update Bundles are stored in the time server. Delete previous update bundles
(such as update489, for instance).

Once a software update has been applied, the update bundle can be deleted (the bundles only
need to be stored in the time server to alleviate the need to transfer them again to perform a
software downgrade.  Otherwise, they can be safely deleted without affecting the time server). 
Having too many upgrade files saved can prevent the update file being applied from being
able to extract.
To delete earlier update files, select each one individually in the drop-down, check only the
checkbox Delete Upgrade File in the screen where you normally select “Update File”. Then click
Submit. This will delete the selected update file. Then run the update process again.

3.7 Technical Support
To request technical support, please go to the "Support" page of the Spectracom Corporate
website, where you can also find additional technical documentation.
Phone support is available during regular office hours under the telephone numbers listed
below. To speed up the diagnosis of your NetClock 9400, please send us the current product
configuration (see "Option Card Identification" on page 1 to find out which option cards are
installed in your unit), and the events log (see "Saving and Downloading Logs" on page 1).
Thank you for your cooperation.

3.7.1 Regional Contact
Spectracom operates globally and has offices in several locations around the world. Our main
offices are listed below:

Country Location Phone

China Beijing +86-10-8231 9601
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Country Location Phone

France Les Ulis, Cedex +33 (0)1 6453 3980

UK Basingstoke, Hampshire +44 (0)1256 303630

USA Rochester, NY +1.585.321.5800

Table 3-1: Spectracom contact information

Additional regional contact information can be found on the Contact page of the Spectracom
corporate website.
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